PSPRadio Forums Forum Index PSPRadio Forums
PSPRadio Forums
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Error Connecting - Timeout

 
Post new topic   Reply to topic    PSPRadio Forums Forum Index -> Problem Reports
View previous topic :: View next topic  
Author Message
dapeeper



Joined: 20 Mar 2006
Posts: 5

PostPosted: Mon Mar 20, 2006 10:28 am    Post subject: Error Connecting - Timeout Reply with quote

Summary:
Error Connecting - Timeout

PSPRadio version 0.37 Final

Description of the bug:
When trying to play streams I always get this error:
Error Connecting - Timeout

Steps required to reproduce:
Start up PSPRadio
Load Playlist
Error Connecting - Timeout!


Any other data (log files/screenshots/playlists/etc)

Network connections work through proxy.
Internet Browser works through proxy (Fired Up Browser) so there is no network/WiFi problem.

I have a v2.0 downgraded to 1.5. Everything else works EXCEPT PSPRadio. Please Help

Exported a Playlist from winamp. This is working fine in winamp. Not even a single station works with PSPRadio. All come up with Error Connecting - Timeout. Below is a sample playlist and the errorlog it produced.


part of Playlist relevant to errorlog:
[playlist]
...
...
File5=http://64.236.34.97:80/stream/1019
Title5=(#1 - 30/21019) S K Y . F M - Country - today's Hit Country with a mix of your favorites
Length5=-1

...
...
NumberOfEntries=26
Version=2


Part of logfile:

23:29:05.107:PSPStream.cpp@74<20>: CPSPStream::SetFile(http://64.236.34.97:80/stream/1019) <URL> called
23:29:05.118:ScreenHandler/PlayListScreen.cpp@276<20>: Calling Play. URI set to 'http://64.236.34.97:80/stream/1019'
23:29:05.249:PSPSound.cpp@152<20>: Play('http://64.236.34.97:80/stream/1019'): m_CurrentState=PLAY
23:29:05.378:PSPSound.cpp@166<80>: Play and state was already playing, restarting decoding/playing
23:29:05.388:PSPRadio.cpp@383<10>: MID_THDECODE_DECODING/MID_SOUND_STARTED(0x56) received, calling OnPlayStateChange(PLAY)
23:29:05.531:PSPSound.cpp@309<10>: ThDecode::Receive Ret=0. event=0x00000010.
23:29:05.657:ScreenHandler/PlayListScreen.cpp@346<10>: OnPlayStateChange(0) called. (this=0x8b98640)
23:29:05.667:PSPSound.cpp@313<10>: ThDecode:: Start Decoder message received.
23:29:05.809:ScreenHandler/PlayListScreen.cpp@365<10>: OnPlayStateChange() Right before the switch
23:29:05.937:PSPSound.cpp@322<50>: ThDecode:: Calling Open For 'http://64.236.34.97:80/stream/1019'
23:29:05.947:ScreenHandler/PlayListScreen.cpp@369<10>: OnPlayStateChange() Case PLAYSTATE_PLAY
23:29:06.081:httpget.cpp@266<20>: http_open(http://64.236.34.97:80/stream/1019) called.
23:29:06.210:ScreenHandler/PlayListScreen.cpp@380<10>: OnPlayStateChange() Case PLAYSTATE_PLAY Done.
23:29:06.220:httpget.cpp@371<20>: url2hostport returns: host='64.236.34.97' ip='0x0' port='80' sptr='/stream/1019'
23:29:06.361:httpget.cpp@421<20>: Resolving host='64.236.34.97'
23:29:06.487:PSPApp_Network.cpp@257<20>: ResolveHostname: Calling aton.. (host='64.236.34.97')
23:29:06.497:httpget.cpp@428<20>: aton/ntoa succeeded, returned addr='0x6122ec40'
23:29:06.638:httpget.cpp@431<20>: http_connect(): Opening socket...
23:29:06.767:httpget.cpp@434<20>: http_connect(): Aquired socket fd=2130706480...
23:29:06.776:httpget.cpp@441<20>: http_connect(): Calling Setsockopt()
23:29:06.905:httpget.cpp@457<20>: Using port '80'
23:29:07.036:httpget.cpp@467<20>: http_connect(): Calling Connect... with port='80', sock=2130706480, addr='0x6122ec40'
23:29:07.046:PSPRadio.cpp@459<10>: ProcessEvents: Unhandled event: MID=0xc1 SID=0x10000000
23:29:07.189:httpget.cpp@472<80>: Connection timeout. iCon=0xffffffff
23:29:07.318:PSPRadio.cpp@304<80>: Error Connecting - Timeout.
23:29:07.328:httpget.cpp@476<20>: http_connect(): Back from Connect...
23:29:07.471:PSPStream.cpp@216<20>: Back from http_open(): socket=-1
23:29:07.614:PSPSound.cpp@411<80>: ThDecode:: Unable to open stream 'http://64.236.34.97:80/stream/1019'.
23:29:07.624:PSPRadio.cpp@368<10>: MID_DECODE_STREAM_OPEN_ERROR received, calling OnPlayStateChange(STOP)
23:29:07.765:PSPSound.cpp@307<10>: ThDecode::Calling Receive
23:29:07.895:ScreenHandler/PlayListScreen.cpp@346<10>: OnPlayStateChange(1) called. (this=0x8b98640)
23:29:07.905:ScreenHandler/PlayListScreen.cpp@365<10>: OnPlayStateChange() Right before the switch
23:29:08.031:ScreenHandler/PlayListScreen.cpp@388<10>: OnPlayStateChange() Case PLAYSTATE_STOP
23:29:08.159:ScreenHandler/PlayListScreen.cpp@414<10>: OnPlayStateChange(STOP): with 0 request
23:29:10.318:ScreenHandler/PlayListScreen.cpp@114<10>: OnButtonReleased(): iButtonMask=0x40
23:29:10.651:ScreenHandler/PlayListScreen.cpp@114<10>: OnButtonReleased(): iButtonMask=0x40
23:29:12.954:ScreenHandler/PlayListScreen.cpp@114<10>: OnButtonReleased(): iButtonMask=0x4000
Back to top
View user's profile Send private message
raf
Site Admin


Joined: 26 Sep 2005
Posts: 730
Location: NC

PostPosted: Mon Mar 20, 2006 10:53 am    Post subject: Re: Error Connecting - Timeout Reply with quote

dapeeper,

Very comprehensive bug report! Thanks!
I'm not positive PSPRadio works through a proxy connection. Anyone else had success with this setup?

Raf.
Back to top
View user's profile Send private message Visit poster's website
dapeeper



Joined: 20 Mar 2006
Posts: 5

PostPosted: Sat Apr 15, 2006 1:13 am    Post subject: Reply with quote

Hey raf

Any progress on this proxy problem?
Back to top
View user's profile Send private message
PSP KEVIN



Joined: 06 Feb 2006
Posts: 56

PostPosted: Sun Apr 16, 2006 11:35 pm    Post subject: Reply with quote

I have this same problem.

PSPRadio *( newest copy )*
GTA eloader *( newest one )*

PSPRadio was working fine, but now it comes up with the error mentioned above.

The WIFI green light comes on,etc....

It seems sometimes it connects, and others it timesout.

Just weird how it worked fine, and now this.

Nothing has changed on my end.
_________________
*( PSP KEVIN )*
Back to top
View user's profile Send private message
PSP KEVIN



Joined: 06 Feb 2006
Posts: 56

PostPosted: Mon Apr 17, 2006 10:40 pm    Post subject: Reply with quote

Anyone have any feedback?
_________________
*( PSP KEVIN )*
Back to top
View user's profile Send private message
PSP KEVIN



Joined: 06 Feb 2006
Posts: 56

PostPosted: Mon Apr 17, 2006 11:02 pm    Post subject: Reply with quote

forget it...this is a problem on my end.
_________________
*( PSP KEVIN )*
Back to top
View user's profile Send private message
raf
Site Admin


Joined: 26 Sep 2005
Posts: 730
Location: NC

PostPosted: Tue Apr 18, 2006 8:32 am    Post subject: Reply with quote

dapeeper wrote:
Hey raf

Any progress on this proxy problem?


Haven't heard anything. We need more reports of people using proxies.. anybody?

Raf.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    PSPRadio Forums Forum Index -> Problem Reports All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Powered By: SourceForge.net Logo